码迷,mamicode.com
首页 > 其他好文 > 详细

A - ACboy needs your help again!

时间:2018-01-28 22:02:55      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:blog   end   分享   gate   注意   for   代码   class   alt   

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can‘t image how dark the room he was put into is, so poor :(. 
As a smart ACMer, you want to get ACboy out of the monster‘s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can‘t solve my problems, you will die with ACboy." 
The problems of the monster is shown on the wall: 
Each problem‘s first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 
and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

InputThe input contains multiple test cases. 
The first line has one integer,represent the number oftest cases. 
And the input of each subproblem are described above.OutputFor each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don‘t have any integer.Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

题目大意:
  FIFO指先输入先输出
  FILO指先输入后输出
解题思路:
  FIFO用栈
  FILO用队列
注意:
  特殊情况:元素为空
第一次写,所以代码很乱,没整理,你可能看不懂,以后尽量整理好代码。
#include <iostream>
#include <string>
#include <stack>
#include <queue>
using namespace std;
int main()
{
    int number, i, k;
    int number2;
    int x;
    int arr[20];
    int t = 0;
    int j;
    string a, b;
    cin >> number;
    for(i = 0; i < number; i++)
    {
        cin >> number2;
        cin >> a;
        if(a == "FILO")
        {
            stack <int> st;
            for(k = 0; k < number2; k++)
            {
                cin >> b;
                if(b == "IN")
                {
                    cin >> x;
                    st.push(x);
                }
                else
                {

                    if(st.size()!=0)
                    {
                        arr[t] = st.top();
                        t++;
                        st.pop();
                    }
                    else
                        {
                            arr[t] = -100;
                            t++;
                        }
                }
            }
        }
        else
        {
            for(k = 0; k < number2; k++)
            {
                queue <int> sc;
                 for(k = 0; k < number2; k++)
            {
                cin >> b;
                if(b == "IN")
                {
                    cin >> x;
                    sc.push(x);
                }
                else
                {

                    if(sc.size()!=0)
                    {
                        arr[t] = sc.front();
                        t++;
                        sc.pop();
                    }
                    else

                        {
                            arr[t] = -100;
                            t++;
                        }
                }
            }
            }
        }
    }
    for(j = 0; j < t; j++)
        if(arr[j]==-100)
        {
            cout << "None" << endl;
        }
        else
        cout << arr[j] << endl;
    return 0;
}

 


  技术分享图片

 

 

 

A - ACboy needs your help again!

标签:blog   end   分享   gate   注意   for   代码   class   alt   

原文地址:https://www.cnblogs.com/w-j-c/p/8372403.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!