码迷,mamicode.com
首页 > 其他好文 > 详细

走楼梯2

时间:2018-03-17 23:24:34      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:post   int   line   ini   str   sts   ret   mat   test   

Description

?One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.
?What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.
?Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 0 <= x <= y < 2^31. For each test case, print a line giving the minimum number of steps to get from x to y.

Sample Input

3
45 48
45 49
45 50

Sample Output

3
3
4

题解

??设d为两点之间的距离,理想情况下,我们总是希望每一步的步数总是比上一步增加,但是由于最后的一步是1,所以不可能是一直上升,那么理想情况下,我们的步数的组成应该是\(123...nn...321\),满足\(d=(1+2+3+...+n)*2\),那么此时总步数达到最小,为2n。
??下面考虑不理想情况,也就是\((1+2+3+...n)*2<d\),记\(d_r=d-(1+2+3+...+n)*2\)
第一种情况
??\(d_r>n\),设\(d_r=n+k=(n+1)+(k-1)\),其中\(k>0\)
那么步数的组成可以为\(123...n(n+1)n...(n-k)(n-k)...321\),由于步数单调递增的,所以总步数也是最小的,为2n+2。
第二种情况
??\(d_r<=n\),那么步数的组成可以为\(123...nn...d_rd_r...321\),由于步数单调递增的,所以总步数也是最小的,为2n+1。
AC代码

#include <iostream>
using namespace std;
int main()
{
    int begin,end,d,steps,n;
    cin>>n;
    while(n--)
    {
        cin >> begin >> end;
        d = end - begin;
        steps = 0;
        int i = 1;
        while(d >= 2 * i)
        {
            d -= 2*i;
            steps += 2;
            ++i;
        }
        if(d > i)
            steps += 2;
        else if(d > 0)
            ++steps;
        cout << steps << endl;
    }
    return 0;
}

走楼梯2

标签:post   int   line   ini   str   sts   ret   mat   test   

原文地址:https://www.cnblogs.com/h-hg/p/8593192.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!