码迷,mamicode.com
首页 > 其他好文 > 详细

L2-008. 最长对称子串

时间:2018-03-22 17:26:32      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:get   col   输入格式   应该   class   是你   pre   pat   stream   

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<queue>
#include<string>
using namespace std;

int main(){
    string str;

    getline(cin, str);
    int len = str.length();
    int maxi = 1;
    for(int i = 1; i < len - 1; i++){
        int cnt = 1, head = i - 1, tail = i + 1;
        while(head >= 0 && tail < len && str[head] == str[tail]){
            cnt += 2;
            head--; tail++;
        }
        maxi = max(maxi, cnt);
        cnt = 0, head = i - 1, tail = i;
        while(head >= 0 && tail < len && str[head] == str[tail]){
            cnt += 2;
            head--; tail++;
        }
        maxi = max(maxi, cnt);
    }
    cout << maxi << endl;
}

 

L2-008. 最长对称子串

标签:get   col   输入格式   应该   class   是你   pre   pat   stream   

原文地址:https://www.cnblogs.com/Pretty9/p/8624425.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!