码迷,mamicode.com
首页 > 其他好文 > 详细

P1134 阶乘问题

时间:2018-05-12 22:38:29      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:under   training   print   输入输出格式   class   包含   cstring   font   bsp   

题目描述

也许你早就知道阶乘的含义,N阶乘是由1到N相乘而产生,如:

12! = 1 x 2 x 3 x 4 x 5 x 6 x 7 x 8 x 9 x 10 x 11 x 12 = 479,001,600

12的阶乘最右边的非零位为6。

写一个程序,计算N(1<=N<=50,000,000)阶乘的最右边的非零位的值。

注意:10,000,000!有2499999个零。

输入输出格式

输入格式:

 

仅一行包含一个正整数N。

 

输出格式:

 

单独一行包含一个整数表示最右边的非零位的值。

 

输入输出样例

输入样例#1: 复制
12
输出样例#1: 复制
6

说明

USACO Training Section 3.2

 

 

题目好理解,

正解cannot understand,

下面给出暴力解法,

十分简单清晰。

 

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;

long long n,ans=1;;


int main()
{
	scanf("%lld",&n);
	for(int i=2;i<=n;++i)
	{
		ans*=i;
		while(ans%10==0) ans/=10;
		ans%=10;
	}
	printf("%lld",ans%10);
}

 

看,是不是很好理解,

 

但,你交吧,29分。

下面来看ac代码

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;

long long n,ans=1;;


int main()
{
	scanf("%lld",&n);
	for(int i=2;i<=n;++i)
	{
		ans*=i;
		while(ans%10==0) ans/=10;
		ans%=10000000;
	}
	printf("%lld",ans%10);
}

 

哇塞,是不是很神奇,居然这样就ac了。

那么,有什么区别呢,

区别就是,

ans在%的时候大一点点,防爆啦2333.

 

P1134 阶乘问题

标签:under   training   print   输入输出格式   class   包含   cstring   font   bsp   

原文地址:https://www.cnblogs.com/Mary-Sue/p/9030028.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!