码迷,mamicode.com
首页 > 编程语言 > 详细

图论_拓扑排序

时间:2018-05-19 00:43:31      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:ios   space   ESS   big   clear   idea   lin   ble   HERE   

对一个有向无环图(Directed Acyclic Graph简称DAG)G进行拓扑排序,是将G中所有顶点排成一个线性序列,使得图中任意一对顶点u和v,若边(u,v)∈E(G),则u在线性序列中出现在v之前。

通常,这样的线性序列称为满足拓扑次序(Topological Order)的序列,简称拓扑序列。简单的说,由某个集合上的一个偏序得到该集合上的一个全序,这个操作称之为拓扑排序。

 

执行步骤

由AOV网构造拓扑序列的拓扑排序算法主要是循环执行以下两步,直到不存在入度为0的顶点为止。
(1) 选择一个入度为0的顶点并输出之;
(2) 从网中删除此顶点及所有出边。
循环结束后,若输出的顶点数小于网中的顶点数,则输出“有回路”信息,否则输出的顶点序列就是一种拓扑序列。

 

例5.7 Leagal or Not (1448)

题目描述:ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
输入:The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
输出:For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".
样例输入:
3 2
0 1
1 2
2 2
0 1
1 0
0 0
样例输出:
YES
NO
#include<iostream>
#include<vector>
#include<queue>
#include<stdio.h>
using namespace std;
vector<int> edge[501];
queue<int>Q;

int main(){
    int inDegree[501];
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0) break;
        for(int i=0;i<n;i++){
            inDegree[i]=0;
            edge[i].clear();
        }
        while(!Q.empty()) Q.pop();
        while(m--){
            int a,b;
            scanf("%d%d",&a,&b);
            inDegree[b]++;
            edge[a].push_back(b);
        }
        for(int i=0;i<n;i++)
            if(inDegree[i]==0)
                Q.push(i);
        int cnt=0;
        while(!Q.empty()){
            int nowP=Q.front();
            Q.pop();
            cnt++;
            for(int i=0;i<edge[nowP].size();i++){
                inDegree[edge[nowP][i]]--;
                if(inDegree[edge[nowP][i]]==0)
                    Q.push(edge[nowP][i]);
            }
        }
        if(cnt==n) puts("YES");
        else puts("NO");
    }
    return 0;
}

技术分享图片

该代码所有节点至多进入队列一次,但在每个结点被取出时我们都要遍历以其为弧尾的边,故复杂度为O(N+E),其中N为结点的个数,E为边的个数。

图论_拓扑排序

标签:ios   space   ESS   big   clear   idea   lin   ble   HERE   

原文地址:https://www.cnblogs.com/exciting/p/9058533.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!