码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1009 FatMouse' Trade(简单贪心 物品可分割的背包问题)

时间:2018-07-15 11:09:35      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:sam   i++   maximum   oom   class   ota   res   ott   efi   

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1009

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 92493    Accepted Submission(s): 32082


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

 

Sample Output
13.333
31.500
 

 

Author
CHEN, Yue
 

 

Source
 分析:
贪心问题,一个类似物品可分割的背包问题
思想:
先按照物品单位价值排序(物品总价值/物品总重量)
每次选择单位价值最大的
选到选择某个物品不能选这个物品的全部的时候就选择物品的一部分(可分割嘛)
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define max_v 1005
struct node
{
    double v,c;
}p[max_v];
bool cmp(node a,node b)
{
    return (a.v/a.c)>(b.v/b.c);
}
int main()
{
    int m,n;
    while(~scanf("%d %d",&m,&n))
    {
        if(n==-1&&m==-1)
            break;
        for(int i=0;i<n;i++)
        {
            scanf("%lf %lf",&p[i].v,&p[i].c);
        }
        sort(p,p+n,cmp);
        double sum=0;
        for(int i=0;i<n;i++)
        {
            if(m>=p[i].c)
            {
                sum+=p[i].v;
                m-=p[i].c;
            }else
            {
                sum+=(m*(p[i].v/p[i].c));
                break;
            }
        }
        printf("%0.3lf\n",sum);
    }
    return 0;
}

 

 

HDU 1009 FatMouse' Trade(简单贪心 物品可分割的背包问题)

标签:sam   i++   maximum   oom   class   ota   res   ott   efi   

原文地址:https://www.cnblogs.com/yinbiao/p/9311914.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!