码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1013 Digital Roots(to_string的具体运用)

时间:2018-07-15 13:46:34      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:应该   转化   class   tput   pac   process   include   accept   bsp   

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1013

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 90108    Accepted Submission(s): 28027


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

 

Sample Input
24
39
0
 

 

Sample Output
6
3
 
 
分析:
这个题有点坑,不能用int输入,也不能用long long 输入
得用字符串
应该是输入太大了
有点编译器可能无法识别to_string,需要下载补丁。。。
比如codeblocks
code:
#include<bits/stdc++.h>
#include<string.h>
using namespace std;
typedef long long LL;
int main()
{
    string s;
    LL sum;
    while(cin>>s)
    {
        if(s=="0")
            break;
        while(s.size()>1)//当size==1的时候,就是答案
        {
            sum=0;
            for(int i=0;i<s.size();i++)
            {
                sum+=(s[i]-0);//累加
            }
            s=to_string(sum);//转化成字符串
        }
        cout<<s<<endl;
    }
    return 0;
}

 

 

HDU 1013 Digital Roots(to_string的具体运用)

标签:应该   转化   class   tput   pac   process   include   accept   bsp   

原文地址:https://www.cnblogs.com/yinbiao/p/9313284.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!