码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1160(两个值的LIS,需dfs输出路径)

时间:2018-07-21 22:47:58      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:class   chmod   while   rem   eve   set   main   子序列   art   

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1160

FatMouse‘s Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20100    Accepted Submission(s): 8909
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

 

Sample Input
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

 

Sample Output
4 4 5 9 7
 

 

Source
 
题目意思:
找到一个最多的老鼠序列,使得序列中的老鼠的体重满足递增,相应老鼠的速度满足递 减。即可要求找出老鼠体重递增,速度递减的最长子序列(不需要连续).
 
分析:
最大上升子序列,先按Wi sort一下,然后LIS,最后dfs输出该序列
code:
#include<bits/stdc++.h>
using namespace std;
#define max_v 10050
struct node
{
    int w,s,index;
}m[max_v];
int pre[max_v];
int dp[max_v];
bool cmp(node a,node b)
{
    if(a.w!=b.w)
        return a.w<b.w;
    else
        return a.s<b.s;
}
void dfs(int i)
{
    int num=m[i].index;
    if(i!=pre[i])
    {
        dfs(pre[i]);
    }
    printf("%d\n",num);
}
int main()
{
    //最大上升子序列,先按Wi sort一下,然后LIS,最后dfs输出该序列
    int n=1;
    while(~scanf("%d %d",&m[n].w,&m[n].s))
    {
        m[n].index=n;
        n++;
    }
    sort(m+1,m+1+n,cmp);
    pre[1]=1;
    dp[1]=1;
    for(int i=2;i<=n;i++)
    {
        int maxx=0;
        int maxi=i;
        for(int j=i-1;j>=1;j--)
        {
            if(m[i].s<m[j].s)
            {
                if(dp[j]>maxx)
                {
                    maxx=dp[j];
                    maxi=j;
                }
            }
        }
        dp[i]=maxx+1;
        pre[i]=maxi;
    }
    int maxx=0;
    int maxi;
    for(int i=1;i<=n;i++)
    {
        if(maxx<dp[i])
        {
            maxx=dp[i];
            maxi=i;
        }
    }
    printf("%d\n",maxx);
    dfs(maxi);
    return 0;
}

 

HDU 1160(两个值的LIS,需dfs输出路径)

标签:class   chmod   while   rem   eve   set   main   子序列   art   

原文地址:https://www.cnblogs.com/yinbiao/p/9347954.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!