码迷,mamicode.com
首页 > 其他好文 > 详细

01-复杂度2 Maximum Subsequence Sum (25 分)

时间:2018-09-29 14:24:29      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:[]   maximum   cup   test   cti   contain   end   Fix   build   

01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (10000). The second line contains Knumbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


C# 代码如下

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace TestConsoleApp1
{
    class Program
    {
        static void Main(string[] args)
        {
            int k = int.Parse(Console.ReadLine());

            List<int> list = new List<int>();
            var ls1 = Console.ReadLine().Split(‘ ‘);

            List<int> ls = new List<int>();
            foreach (var item in ls1)
            {
                ls.Add(int.Parse(item));

            }

            if (ls.Max() < 0)
            {
                ls.IndexOf(ls.Max());
                {

                }
            }

            int max = 0, nowmax = 0;
            int x = 0, y = 0;
            int nowX = 0, nowY = 0;

            if (ls.Max() < 0)
            {
                x = 0;
                y = ls.Count - 1;
                {
                    max = 0;
                }
                goto AAA;
            }
            if (ls.Max() == 0)
            {
                x = y = ls.IndexOf(0);
                {
                    max = 0;
                }
                goto AAA;
            }


            for (int i = 0; i < ls.Count; i++)
            {


                var temp = ls[i];

                if (nowmax == 0)
                {
                    nowX = i;
                }

                nowmax += temp;
                if (nowmax > 0)
                {
                    nowY = i;
                    if (nowmax > max)
                    {
                        max = nowmax;
                        x = nowX;
                        y = nowY;
                    }
                }
                else
                {
                    nowmax = 0;
                }

            }

  AAA:
            int tempX = x;
            while (tempX > 0)
            {
                if (ls[tempX - 1] == 0)
                {
                    tempX--;
                }
                else
                    break;
            }
            x = tempX;

          
            StringBuilder sb = new StringBuilder();

            sb.Append(max + " ");
            sb.Append(ls[x] + " ");
            sb.Append(ls[y]);

            Console.Write(sb.ToString());
        }
    }
}

  

01-复杂度2 Maximum Subsequence Sum (25 分)

标签:[]   maximum   cup   test   cti   contain   end   Fix   build   

原文地址:https://www.cnblogs.com/interim/p/9723180.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!