码迷,mamicode.com
首页 > 其他好文 > 详细

upc 3026 Exponial

时间:2018-10-06 22:11:53      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:eal   math.h   onclick   const   ali   lin   open   while   name   

Exponial

时间限制: 1 Sec  内存限制: 64 MB
提交: 229  解决: 54
[提交] [状态] [讨论版] [命题人:外部导入]

题目描述

技术分享图片
Illustration of exponial(3) (not to scale), Picture by C.M. de Talleyrand-Périgord via Wikimedia Commons Everybody loves big numbers (if you do not, you might want to stop reading at this point). There are many ways of constructing really big numbers known to humankind, for instance:
技术分享图片
In this problem we look at their lesser-known love-child the exponial , which is an operation de?ned for all positive integers n as
技术分享图片
For example, exponial(1) = 1 and  技术分享图片which is already pretty big. Note that exponentiation is right-associative:  技术分享图片.
Since the exponials are really big, they can be a bit unwieldy to work with. Therefore we would like you to write a program which computes exponial(n) mod m (the remainder of exponial(n) when dividing by m).

 

输入

The input consists of two integers n (1 ≤ n ≤ 109 ) and m (1 ≤ m ≤ 109 ).

 

输出

Output a single integer, the value of exponial(n) mod m.

 

样例输入

2 42

 

样例输出

2

题意

给一个N,M,求技术分享图片模M的结果。

分析

欧拉降幂的经典例题

欧拉降幂公式:

技术分享图片

写递归求答案就可以了。

技术分享图片
///  author:Kissheart  ///
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#define INF 0x3f3f3f3f
#define FAST_IO ios::sync_with_stdio(false)
const double PI = acos(-1.0);
const double eps = 1e-6;
const int MAX=1e6+10;
long long int mod;
typedef long long ll;
using namespace std;
#define gcd(a,b) __gcd(a,b)
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
inline ll qpow(ll a,ll b,ll mod){ll r=1,t=a; while(b){if(b&1)r=(r*t)%mod;b>>=1;t=(t*t)%mod;}return r;}
//inline ll inv1(ll b){return qpow(b,mod-2);}
inline ll exgcd(ll a,ll b,ll &x,ll &y){if(!b){x=1;y=0;return a;}ll r=exgcd(b,a%b,y,x);y-=(a/b)*x;return r;}
inline ll read(){ll x=0,f=1;char c=getchar();for(;!isdigit(c);c=getchar()) if(c==-) f=-1;for(;isdigit(c);c=getchar()) x=x*10+c-0;return x*f;}
//freopen( "in.txt" , "r" , stdin );
//freopen( "data.txt" , "w" , stdout );

ll a[]={0,1,2,9,(1<<18)},n;
ll phi(ll n)
{
    ll ans=n;
    for (ll i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            ans-=ans/i;
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        ans-=ans/n;
    return ans;
}


ll f(ll n,ll m)
{
    if(m==1) return 1;
    if(n<=4)
    {
        if(a[n]>=m) return a[n]%m+m;
        return a[n];
    }
    ll exp=f(n-1,phi(m));
    return qpow(n,exp,m)+m;
}
int main()
{

    scanf("%lld%lld",&n,&mod);
    ll exp=f(n-1,phi(mod));
    ll ans=qpow(n,exp,mod)%mod;
    printf("%lld\n",ans%mod);

    return 0;
}
View Code

 

upc 3026 Exponial

标签:eal   math.h   onclick   const   ali   lin   open   while   name   

原文地址:https://www.cnblogs.com/Kissheart/p/9748676.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!