码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1027 Ignatius and the Princess II【全排列】

时间:2019-01-13 00:07:46      阅读:232      评论:0      收藏:0      [点我收藏+]

标签:case   inpu   程序   compose   ++   man   seve   pen   space   

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11536 Accepted Submission(s): 6640

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it‘s easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It‘s easy, isn‘t is? Hahahahaha......"
Can you help Ignatius to solve this problem?

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub‘s demand. The input is terminated by the end of file.

Output
For each test case, you only have to output the sequence satisfied the BEelzebub‘s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input
6 4
11 8

Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

问题链接HDU1027 Ignatius and the Princess II
问题简述:(略)
问题分析
????全排列问题,用STL的算法实现比较简单。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* HDU1027 Ignatius and the Princess II */

#include <bits/stdc++.h>

using namespace std;

const int N = 1000;
int a[N];

int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m)) {
        for(int i = 0; i < n; i++)
            a[i] = i + 1;

        for(int i = 1; i < m; i++)
            next_permutation(a, a + n);

        for(int i = 0; i < n; i++) {
            if(i) printf(" ");
            printf("%d", a[i]);
        }
        printf("\n");
    }

    return 0;
}

HDU1027 Ignatius and the Princess II【全排列】

标签:case   inpu   程序   compose   ++   man   seve   pen   space   

原文地址:https://www.cnblogs.com/tigerisland45/p/10261408.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!