码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3070 Fibonacci【矩阵快速幂】

时间:2019-01-13 00:22:20      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:space   clu   struct   rod   ati   矩阵快速幂   The   ios   set   

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20098 Accepted: 13850

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享图片.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

技术分享图片.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

技术分享图片.

Source

Stanford Local 2006

问题链接POJ3070 Fibonacci
问题简述:(略)
问题分析
????矩阵快速幂的模板题。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* POJ3070 Fibonacci */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int MOD = 1e4;
const int N = 2;

struct Matrix
{
    int m[N][N];
    Matrix() {}
    Matrix operator*(Matrix const &a)const
    {
        Matrix b;
        memset(b.m, 0, sizeof(b.m));
        for (int i = 0 ;i < N; i++)
            for (int j = 0; j < N; j++)
                for (int k = 0; k < N; k++)
                    b.m[i][j] = (b.m[i][j] + this->m[i][k] * a.m[k][j]) % MOD;
        return b;
    }
};

Matrix pow_mod(Matrix a, int n)
{
    Matrix b;
    memset(b.m, 0, sizeof(b.m));
    for (int i = 0; i < N; i++)
        b.m[i][i] = 1;
    while (n > 0)
    {
        if (n & 1) b = b * a;
        a = a * a;
        n >>= 1;
    }
    return b;
}

int main()
{
    Matrix a;
    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            a.m[i][j] = 1;
    a.m[1][1] = 0;

    int n;
    while (~scanf("%d", &n) && n != -1)
    {
        Matrix b = pow_mod(a, n);
        printf("%d\n", b.m[0][1]);
    }

    return 0;
}

POJ3070 Fibonacci【矩阵快速幂】

标签:space   clu   struct   rod   ati   矩阵快速幂   The   ios   set   

原文地址:https://www.cnblogs.com/tigerisland45/p/10261279.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!