码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3045--Cow Acrobats(theory proving)

时间:2019-02-19 10:27:44      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:bottom   integer   test   tput   soc   esc   Plan   rate   space   

Farmer John‘s N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren‘t terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Input

* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 

Output

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Input

3
10 3
2 5
3 3

Sample Output

2

Hint

OUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.
 
 
按牛的体重和力量之和进行排序。

因此,如果A在上,B在下,则有:
A: Ra = S + Wb - Xa;
B: Rb = S - Xb;
反之如下:
A: Ra = S - Xa;
B: Rb = S + Wa - Xb;

如果我们定义一方案好于而方案则有:
S + Wb - Xa < S + Wa - Xb;
则: Wa + Xa < Wb + Xb;

 
 
#include<iostream>
#include<algorithm>
using namespace std;
struct Cow{
    int weight;
    int strength;
    bool operator<(const Cow& other)const{
        return other.weight+other.strength<weight+strength;
    }
}cows[50005];
int main(){
    int n;
    cin>>n;
    int total=0;
    for(int i=0;i<n;i++){
        cin>>cows[i].weight>>cows[i].strength;        
        total+=cows[i].weight;
    }
    sort(cows,cows+n);
    int m=-INT_MAX;
    for(int i=0;i<n;i++){
        total-=cows[i].weight;
        m=max(m,total-cows[i].strength);
    }
    cout<<m<<endl;
    return 0;
}

 

POJ3045--Cow Acrobats(theory proving)

标签:bottom   integer   test   tput   soc   esc   Plan   rate   space   

原文地址:https://www.cnblogs.com/albert67/p/10399417.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!