码迷,mamicode.com
首页 > 其他好文 > 详细

PAT A1128 N Queens Puzzle (20 分)

时间:2019-02-20 21:39:03      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:.com   mes   aci   jpg   contain   list   set   class   ott   

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q?1??,Q?2??,?,Q?N??), where Q?i?? is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens‘ solution.

技术图片 技术图片
Figure 1   Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K200). Then K lines follow, each gives a configuration in the format "Q?1?? Q?2?? ... Q?N??", where 4N1000 and it is guaranteed that 1Q?i??N for all i=1,?,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES
 
#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
int k,n;
int a[1010];
int main(){
  scanf("%d",&k);
  for(int i=0;i<k;i++){
    fill(a,a+1010,0);
    scanf("%d",&n);
    int flag=0;
    for(int j=1;j<=n;j++){
      int tmp;
      scanf("%d",&tmp);
      if(flag==0){
        a[j]=tmp;
      for(int q=1;q<j;q++){
        if(abs(j-q)==abs(a[j]-a[q]) || a[j]==a[q]){
          flag=1;
          break;
        }
      }}
      else continue;
    }
    printf("%s\n",flag==1?"NO":"YES");
  }
}

注意点:测试点1是有两个在同一行,所以这题是不仅判断对角线,还有同行,但肯定不会同列。

PAT A1128 N Queens Puzzle (20 分)

标签:.com   mes   aci   jpg   contain   list   set   class   ott   

原文地址:https://www.cnblogs.com/tccbj/p/10409234.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!