码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3176 Cow Bowling 保龄球 数塔问题 DP

时间:2014-10-18 14:06:11      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:acm   poj   dp   

题目链接:POJ 3176 Cow Bowling

Cow Bowling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14044   Accepted: 9310

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

Source


题意:

从数塔的第一层走到最底层,但只能沿对角线走,求路径上的数的和的最大值。

分析:

从最底层向上考虑,路径上的和的大小取决于直接取决于下面两个数的大小。因而采用自顶向上方法,逐步向上走,走到最顶层,每次都选择最大的和,这样最后的结果就保存在了最顶层。

状态转移方程:dp[i][j] = max(dp[i+1][j], dp[i+1][j+1])+A[i][j];

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX_N = 400;
int dp[MAX_N][MAX_N];
int N, A[MAX_N][MAX_N];
void solve() {
    memset(dp, 0, sizeof(dp));
    for(int i = 1; i <= N; i++) dp[N][i] = A[N][i];
    for(int i = N-1; i >= 1; i--)
        for(int j = 1; j <= i; j++)
            dp[i][j] = A[i][j]+max(dp[i+1][j], dp[i+1][j+1]);
    printf("%d\n", dp[1][1]);
}
int main() {
    while(~scanf("%d", &N)) {
        for(int i = 1; i <= N; i++) 
            for(int j = 1; j <= i; j++)
                scanf("%d", &A[i][j]);
        solve();
    }
    return 0;
}


POJ 3176 Cow Bowling 保龄球 数塔问题 DP

标签:acm   poj   dp   

原文地址:http://blog.csdn.net/u011439796/article/details/40210651

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!