码迷,mamicode.com
首页 > 其他好文 > 详细

1003 Emergency (Dijkstra)

时间:2019-03-01 18:48:50      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:ast   highlight   teams   ber   scribe   code   space   current   bin   

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤) - the number of cities (and the cities are numbered from 0 to N1), M - the number of roads, C?1?? and C?2?? - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c?1??, c?2?? and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C?1?? to C?2??.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C?1?? and C?2??, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

  

此道题需要输出最短距离条数,最短路径中的最大点权,需添加这两个数组,并在更新d[v]的同时更新

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=550;
const int INF=0x3fffffff;
int teams[maxn],G[maxn][maxn],vis[maxn]={0},d[maxn];
int w[maxn]={0},num[maxn]={0};//最大点权,最短路径条数 
int n,m,in,out;

void dijkstra(int x){
    d[x]=0;
    vis[x]=1;
    num[x]=1;
    w[x]=teams[x];
    int newp=x;
    for(int i=0;i<n-1;i++){
        int zuijin=INF,index=-1;
        for(int j=0;j<n;j++){
            if(G[newp][j]+d[newp]==d[j]){
                num[j]+=num[newp];
                if(w[j]<w[newp]+teams[j])
                    w[j]=w[newp]+teams[j];
            }else if(G[newp][j]+d[newp]<d[j]){
                d[j]=G[newp][j]+d[newp];
                num[j]=num[newp];
                w[j]=w[newp]+teams[j];
            }    
        }
        for(int j=0;j<n;j++){
            if(vis[j]==false&&d[j]<=zuijin){
                zuijin=d[j];
                index=j;
            }
        }
        vis[index]=1;
        newp=index;
    }
}

int main(){
    fill(G[0],G[0]+maxn*maxn,INF);
    fill(d,d+maxn,INF);
    scanf("%d %d %d %d",&n,&m,&in,&out);
    for(int i=0;i<n;i++)
        scanf("%d",&teams[i]);
    int t1,t2,ww;
    for(int i=0;i<m;i++){
        scanf("%d %d %d",&t1,&t2,&ww);
        G[t1][t2]=G[t2][t1]=ww;
    }
    dijkstra(in);
    printf("%d ",num[out]);
    printf("%d",w[out]);
    return 0;
}

 

1003 Emergency (Dijkstra)

标签:ast   highlight   teams   ber   scribe   code   space   current   bin   

原文地址:https://www.cnblogs.com/exciting/p/10457947.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!