码迷,mamicode.com
首页 > 其他好文 > 详细

Scrambled Polygon

时间:2019-03-16 23:45:23      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:sort   cep   axis   cond   mission   otherwise   current   join   round   

Scrambled Polygon
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10474   Accepted: 4953

Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly once, one comes back to the starting vertex. 

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn‘t have any "dents".) 
技术图片

The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0).

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with (0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 
技术图片 
技术图片

Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999. The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip taken along the polygon‘s border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

Sample Input

0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10

Sample Output

(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)
#include <iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node{
      int x,y;
}p[66];
bool cmp(node a,node b){
    return a.x*b.y-a.y*b.x>0;
}
int main()
{
    int cnt=0;
    while(~scanf("%d%d",&p[cnt].x,&p[cnt].y))cnt++;
    sort(p+1,p+cnt,cmp);
    for(int i=0;i<cnt;i++)printf("(%d,%d)\n",p[i].x,p[i].y);
    return 0;
}

 

Scrambled Polygon

标签:sort   cep   axis   cond   mission   otherwise   current   join   round   

原文地址:https://www.cnblogs.com/czy-power/p/10544898.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!