码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3041 Asteroids

时间:2019-04-08 13:27:21      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:minimum   匈牙利算法   iostream   std   cross   div   through   present   EAP   

http://poj.org/problem?id=3041

 

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <cstdio>
using namespace std;

const int maxn = 550;
int N, K;
int mp[maxn][maxn];
int vis[maxn], match[maxn];

int path(int u) {
    for(int v = 1; v <= N; v ++) {
        if(mp[u][v] && !vis[v]) {
            vis[v] = 1;
            if(match[v] == -1 || path(match[v])) {
                match[v] = u;
                return 1;
            }
        }
    }
    return 0;
}

int main() {
    memset(mp, 0, sizeof(mp));
    memset(match, -1, sizeof(match));
    scanf("%d%d", &N, &K);

    for(int i = 0; i < K; i ++) {
        int x, y;
        scanf("%d%d", &x, &y);
        mp[x][y] = 1;
    }
    int cnt = 0;
    for(int i = 1; i <= N; i ++) {
        memset(vis, 0, sizeof(vis));
        if(path(i))
            cnt ++;
        else continue;
    }
    printf("%d\n", cnt);
    return 0;
}

  匈牙利算法 求最小点集覆盖 

POJ 3041 Asteroids

标签:minimum   匈牙利算法   iostream   std   cross   div   through   present   EAP   

原文地址:https://www.cnblogs.com/zlrrrr/p/10669651.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!