码迷,mamicode.com
首页 > 其他好文 > 详细

qemu-kvm-1.1.0源码中关于迁移的代码分析

时间:2014-05-15 00:18:40      阅读:376      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   c   

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino‘s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens‘‘ number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

poj的第二题,本以为可以轻松解决,实际写完之后查错花了不少时间。我一开始的思路是用结构体记录每条电话号码以及它的出现次数,输入完成后快排处理。一直返回无情的TLE。。。后来想不到怎么优化了,上网搜了一下将电话直接转化成数,因为只有7位,不会超int,思路还是比较简单。。但要几个地方,用cnt计数器记录每一个电话出现的次数,输出还要用0填充。。(贡献了WA)。


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int m[50]={ 2,2,2,  //表
            3,3,3,
            4,4,4,
            5,5,5,
            6,6,6,
            7,7,7,7,
            8,8,8,
            9,9,9,-1 },num[100004];
int cmp(const void *a , const void *b)
{
    return *(int *)a-*(int *)b;
}
int main()
{
    int n,k=0;
    char s[50];
    scanf("%d",&n);
    while (n--) {
        scanf("%s",s);
        int tmp=0;
        for(int i=0;s[i];i++) {
            if(s[i]!=‘-‘) {
                tmp*=10;
                if(s[i]>=‘0‘ && s[i]<=‘9‘) tmp+=s[i]-‘0‘;
                else if(s[i]>=‘A‘ && s[i]<=‘Z‘) tmp+=m[s[i]-‘A‘];
            }
        }
       num[k++]=tmp;
    }
    qsort(num,k,sizeof(num[0]),cmp); //保证字典序,其实就是数从小到大
    num[k]=-1;  //给第k+1个赋值一个一定不与前一个相等的数
    int cnt=1,ok=0;  //cnt计数
    for(int i=0;i<k;i++) {
        if(num[i]==num[i+1]) cnt++;
        else if(cnt>1) {
            printf("%03d-%04d %d\n",num[i]/10000,num[i]%10000,cnt);  //!!用0填充!!
            ok=1;
            cnt=1;
        }
    }
    if(!ok) printf("No duplicates.\n");
    return 0;
}




qemu-kvm-1.1.0源码中关于迁移的代码分析,布布扣,bubuko.com

qemu-kvm-1.1.0源码中关于迁移的代码分析

标签:des   style   blog   class   code   c   

原文地址:http://blog.csdn.net/wan_hust/article/details/25805431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!