码迷,mamicode.com
首页 > 其他好文 > 详细

数列求和-加强版(20 分) C

时间:2019-05-21 19:07:22      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:输出   position   dig   struct   class   输入   for   数列   数字   

习题2.3 数列求和-加强版 (20 分)

给定某数字A(1≤A≤9)以及非负整数N(0≤N≤100000),求数列之和S=A+AA+AAA+?+AA?A(N个A)。例如A=1, N=3时,S=1+11+111=123。

输入格式:

输入数字A与非负整数N。

输出格式:

输出其N项数列之和S的值。

输入样例:

1 3

输出样例:

123

#include <stdio.h>

typedef int ElementType;
typedef int Position;
typedef int Count;

struct Int{
    ElementType Digit[100000];
    Position Last;
};

typedef struct Int Integer;

int main(void)
{
    ElementType num;
    Count n;
    Integer a = {0};
    
    a.Last=0;
    scanf("%d %d", &num, &n);
    
    ElementType temp;
    for(Count i=1;i<=n;i++){
        if(i-1>a.Last)
            a.Last++;
        a.Digit[i-1] += (n-i+1)*num+temp;
        if(n!=i){
            temp = a.Digit[i-1]/10;
            a.Digit[i-1] %= 10;
        }
    }
    
    for(Position i=a.Last;i>=0;i--)
        printf("%d", a.Digit[i]); 
    printf("\n");
    
    return 0;
}

数列求和-加强版(20 分) C

标签:输出   position   dig   struct   class   输入   for   数列   数字   

原文地址:https://www.cnblogs.com/nonlinearthink/p/10901659.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!