码迷,mamicode.com
首页 > 其他好文 > 详细

[Wythoff博弈] poj 1067 取石子游戏

时间:2014-05-15 19:31:59      阅读:285      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   c   

题目链接:

http://poj.org/problem?id=1067

取石子游戏
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33556   Accepted: 11180

Description

有两堆石子,数量任意,可以不同。游戏开始由两个人轮流取石子。游戏规定,每次有两种不同的取法,一是可以在任意的一堆中取走任意多的石子;二是可以在两堆中同时取走相同数量的石子。最后把石子全部取完者为胜者。现在给出初始的两堆石子的数目,如果轮到你先取,假设双方都采取最好的策略,问最后你是胜者还是败者。

Input

输入包含若干行,表示若干种石子的初始情况,其中每一行包含两个非负整数a和b,表示两堆石子的数目,a和b都不大于1,000,000,000。

Output

输出对应也有若干行,每行包含一个数字1或0,如果最后你是胜者,则为1,反之,则为0。

Sample Input

2 1
8 4
4 7

Sample Output

0
1
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题目意思:

两堆石子,两个人轮流取,每次可以去一堆中的任意个,或者取两堆中的相同个,两个人都以最优的决策,求谁会赢。

解题思路:

裸的威佐夫博弈。

威佐夫博弈的奇异局势为ak=[k*(1+sqrt(5))/2] bk=ak+k (k=0,1,2,..,n)

先求出k‘=[ak/(1+sqrt(5))*2],然后带进式子判断是否都满足。否则把k‘++,再带进去试试,看满不满足。如果不满足,就可以判断不是奇异局势,先拿赢。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

int a,b;

int main()
{
   //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   //printf("%lf\n",7.0*(sqrt(5)+1)/2.0);
   while(~scanf("%d%d",&a,&b))
   {
       if(a>b)
          swap(a,b);
       int k1=(int)(floor(a*(sqrt(5.0)-1)/2.0));

       int k2=(int)(floor(k1*(sqrt(5.0)+1)/2));


       if(k2==a&&k2+k1==b)
       {
           printf("0\n");
           continue;
       }
       k1++;
       k2=(int)(floor(k1*(sqrt(5.0)+1)/2));

       if(k2==a&&k2+k1==b)
       {
           printf("0\n");
           continue;
       }
       printf("1\n");

   }
   return 0;
}




  

[Wythoff博弈] poj 1067 取石子游戏,布布扣,bubuko.com

[Wythoff博弈] poj 1067 取石子游戏

标签:des   style   blog   class   code   c   

原文地址:http://blog.csdn.net/cc_again/article/details/25896725

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!