码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2241——The Tower of Babylon

时间:2014-11-01 10:07:15      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:dp

The Tower of Babylon
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2207   Accepted: 1244

Description

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:
The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input

The input will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

Source

Ulm Local 1996

每一个箱子产生6种状态,然后如果两个箱子可以叠放,就连一条边,最后记忆化搜索就行

#include<map>  
#include<set>  
#include<list>  
#include<stack>  
#include<queue>  
#include<vector>  
#include<cmath>  
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
  
using namespace std;  
  
struct node  
{  
    int x, y, z;  
}block[200];  
  
int cnt;  
int dp[200];  
bool g[200][200];  
  
bool is_ok(node a, node b)  
{  
    if(a.x < b.x && a.y < b.y)  
    {  
        return true;  
    }  
    return false;  
}  
  
void get_block(int x, int y, int z)  
{  
    block[cnt].x = x;  
    block[cnt].y = y;  
    block[cnt].z = z;  
    cnt++;  
}  
  
int dfs(int i)  
{  
    if(dp[i])  
    {  
        return dp[i];  
    }  
    dp[i] = block[i].z;  
    for(int j = 0; j < cnt; j++)  
    {  
        if(g[i][j])  
        {  
            dp[i] = max(dp[i], dfs(j) + block[i].z);  
        }  
    }  
    return dp[i];  
}  
  
int main()  
{  
    int n;  
    int icase = 1;  
    while (~scanf("%d", &n), n)  
    {  
        int x, y, z;  
        cnt = 0;  
        for(int i = 0; i < n; i++)  
        {  
            scanf("%d%d%d", &x, &y, &z);  
            get_block(x, y, z);  
            get_block(x, z, y);  
            get_block(y, x, z);  
            get_block(y, z, x);  
            get_block(z, x, y);  
            get_block(z, y, x);  
        }  
        memset( dp, 0, sizeof(dp) );  
        memset( g, 0, sizeof(g) );  
        for (int i = 0; i < cnt; i++)  
        {  
            for(int j = 0; j < cnt; j++)  
            {  
                if( is_ok(block[i], block[j]) )  
                {  
                    g[i][j] = 1;  
                }  
            }  
        }  
        int ans = 0;  
        for(int i = 0; i < cnt; i++)  
        {  
            ans = max(ans, dfs(i));  
        }  
        printf("Case %d: maximum height = %d\n", icase++, ans);  
    }  
    return 0;  
} 


POJ2241——The Tower of Babylon

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/40674189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!