码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1009 Product of Polynomials (25分)

时间:2020-01-19 23:53:57      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:baseline   file   class   ==   must   specific   tmp   nta   lis   

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1, 0.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 3 3.6 2 6.0 1 1.6

多项式相乘,我们需要注意去使用map进行存储,去除结果为0的,然后输出即可

#include <iostream>
#include <vector>
#include <map>
using namespace std;
struct poly{
    double coeff;
    int expo;
};
int main()
{
    int M;poly tmp;
    vector<poly> poly1,poly2;
    /**input*/
    cin>>M;
    while(M--){
        cin>>tmp.expo>>tmp.coeff;
        poly1.push_back(tmp);
    }
    cin>>M;
    while(M--){
        cin>>tmp.expo>>tmp.coeff;
        poly2.push_back(tmp);
    }
    map<int,double,greater<int>> m;
    /**计算*/
    for(int i=0;i<poly1.size();i++)
        for(int j=0;j<poly2.size();j++)
            m[poly1[i].expo+poly2[j].expo]+=poly1[i].coeff*poly2[j].coeff;
    /**去0*/
    for(auto it=m.begin();it!=m.end();it++)
        if(it->second==0) m.erase(it);
    /**输出*/
    cout<<m.size();
    for(auto it=m.begin();it!=m.end();it++)
        printf(" %d %.1f",it->first,it->second);
    system("pause");
    return 0;
}

PAT Advanced 1009 Product of Polynomials (25分)

标签:baseline   file   class   ==   must   specific   tmp   nta   lis   

原文地址:https://www.cnblogs.com/littlepage/p/12215791.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!