码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1047 Student List for Course (25分)

时间:2020-01-29 19:46:43      阅读:81      评论:0      收藏:0      [点我收藏+]

标签:and   space   clipboard   code   positive   provides   advance   pre   sim   

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤), the total number of students, and K (≤), the total number of courses. Then N lines follow, each contains a student‘s name (3 capital English letters plus a one-digit number), a positive number C (≤) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students‘ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
 

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

这题也考察stl的用法,超时把输入用scanf,输出用printf就行

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
int main() {
    unordered_map<int, vector<string>> m;
    int M, N, num, tmp;
    string name;
    cin >> M >> N;
    for(int i = 0; i < M; i++) {
        cin >> name >> num;
        while(num--) {
            cin >> tmp;
            m[tmp].push_back(name);
        }
    }
    for(int i = 1; i <= N; i++) {
        sort(m[i].begin(), m[i].end());
        printf("%d %d\n", i, m[i].size());
        for(int j = 0; j < m[i].size(); j++)
            printf("%s\n", m[i][j].c_str());
    }
    system("pause");
    return 0;
}

 

PAT Advanced 1047 Student List for Course (25分)

标签:and   space   clipboard   code   positive   provides   advance   pre   sim   

原文地址:https://www.cnblogs.com/littlepage/p/12241031.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!