码迷,mamicode.com
首页 > 其他好文 > 详细

A-Leftbest

时间:2020-03-08 23:30:24      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:hose   内存   c代码   mat   auto   rest   eve   个数   using   

A-Leftbest

原题:

Jack is worried about being single for his whole life, so he begins to use a famous dating app. In this app, the user is shown single men/women‘s photos one by one, and the user may choose between “yes” and “no”. Choosing “yes” means an invitation while choosing “no” means nothing. The photos would be shown one by one until the number of rest photos to be shown reaches zero. Of course, efficient and single Jack would always choose “yes”.

When viewing photos, Jack would have a “fake impression point” on every photo, which is not accurate. To calculate the “true impression point” of one photo, Jack would recall the “fake impression point” of every previous photo whose “fake impression point” is larger than this photo, and regard the smallest “fake impression point” of them as the “true impression point” of this photo. Jack would like to sum the “true impression point” of all photos as the outcome of his effort.

Note that if such a larger “fake impression point” does not exist, the “true impression point” of this photo is zero.

Input

The first line contains an integer (1) --- the number of photos.

The second line contains n integers a?1??, a?2??, …, a?n?? where a?i?? (0) is the “fake impression point” of the i-th photo.

Output

Output a single integer --- the sum of the “true impression point” of all photos.

Sample Input

4
2 1 4 3
 

Sample Output

6
 
作者: NEUACM
单位: 东北大学
时间限制: 1000 ms
内存限制: 64 MB
代码长度限制: 16 KB

 题意: 输入n个数存入数组 a[],求和,求和的方式是 a[i]的值为前面所有大于a[i]的数中最小的那个,如果没有则为0;

思路:先介绍两个函数

lower_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,找到返回该数字的地址,不存在则返回end。

upper_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于num的数字,找到返回该数字的地址,不存在则返回end。
前提是:数组必须从小到大排序。

由题得选择 upper_bound 函数,从小到大排序 则用set

 

AC代码:

#include<bits/stdc++.h>
#include<iostream>
#include<vector>
#include<queue>
#include<string>
#include<list>
#include<set>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;

int main()
{
    set<ll> v;
    ll n;
    cin>>n;
    ll node[maxn];
    for(int i=0;i<n;i++)
    {
        cin>>node[i];
    } 
    ll sum = 0;
    v.insert(node[0]);
    for(int i=1;i<n;i++)
    {
        auto it = v.upper_bound(node[i]);
        if(it!=v.end())
        {
            sum+=*it;
        }
        v.insert(node[i]);
    }
    cout<<sum<<endl;
    return 0;
}

 

 

A-Leftbest

标签:hose   内存   c代码   mat   auto   rest   eve   个数   using   

原文地址:https://www.cnblogs.com/subject/p/12445777.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!