码迷,mamicode.com
首页 > 其他好文 > 详细

1008 Elevator

时间:2020-03-27 12:53:59      阅读:79      评论:0      收藏:0      [点我收藏+]

标签:begin   seconds   mat   sts   tst   +=   sam   ++   clip   

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1
 

Sample Output:

41

 

题意:

一个电梯走完所要求的楼层,上一层需要6分钟,下一层需要4分钟,每到达一层需要等5分钟。

 

Code:

#include<iostream>
#include<vector>

using namespace std;

int main() {
    int n, t;
    cin >> n;

    vector<int> req;

    int total = 0, pre = 0;
    for (int i = 0; i < n; ++i) {
        cin >> t;
        if (t > pre) {
            total += (t - pre) * 6 + 5;
            pre = t;
        } else {
            total += (pre - t) * 4 + 5;
            pre = t;
        }
    }

    cout << total;

    return 0;
}

  

 

1008 Elevator

标签:begin   seconds   mat   sts   tst   +=   sam   ++   clip   

原文地址:https://www.cnblogs.com/ruruozhenhao/p/12580392.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!