码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1051. Wooden Sticks

时间:2020-04-08 20:48:30      阅读:82      评论:0      收藏:0      [点我收藏+]

标签:sum   size   ons   mit   limited   amp   contain   work   class   

HDOJ 1051. Wooden Sticks

题目

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l <= l‘ and w <= w‘. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

ac代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=10000+50;
int vis[maxn];
struct Node{
    int l,w;
}e[maxn];
bool cmp(Node x,Node y){
    if(x.l==y.l) return x.w<y.w;
    else return x.l<y.l;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
    	memset(vis,0,sizeof(vis));
    	int sum=0;
        int m;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
            scanf("%d%d",&e[i].l,&e[i].w);
        sort(e+1,e+m+1,cmp);           
        for(int i=1;i<=m;i++){
            if(vis[i])
				continue;
            int maxx=e[i].w;
            for(int j=i+1;j<=m;j++){
                if(!vis[j]&&maxx<=e[j].w) {
                    vis[j]=1;
                    maxx=e[j].w;
                }
            }
            sum++;
        }
        printf("%d\n",sum);  
    }
    return 0;
}

HDOJ 1051. Wooden Sticks

标签:sum   size   ons   mit   limited   amp   contain   work   class   

原文地址:https://www.cnblogs.com/hellohhy/p/12662463.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!