码迷,mamicode.com
首页 > 其他好文 > 详细

HDoj 2056 Rectangles

时间:2020-04-15 13:51:02      阅读:82      评论:0      收藏:0      [点我收藏+]

标签:ali   不能   pid   com   and   second   blank   cal   lan   

Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 

 

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
 

 

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 

 

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
 

 

Sample Output
1.00 56.25
 

 

Author
seeyou
 

 

Source
 

 

Recommend
linle   |   We have carefully selected several similar problems for you:  2057 2058 2062 2060 2059 
 
 
 
 
注意两个矩形完全不相交时不能使用公式计算,直接为0
C++代码如下:
#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    double x[4];
    double y[4];
    while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x[0],&y[0],&x[1],&y[1],&x[2],&y[2],&x[3],&y[3]) !=EOF )
    {
        if( (min(x[0],x[1])>max(x[2],x[3]))  ||  (max(x[0],x[1])<min(x[2],x[3])) )         //首先排除两个矩形左右错开,此时面积为0
        {
            printf("0.00\n");
            continue;
        }
        if( (min(y[0],y[1])>max(y[2],y[3]))  ||  (max(y[0],y[1])<min(y[2],y[3])) )         //排除两个矩形上下错开,此时面积为0
        {
            printf("0.00\n");
            continue;
        }
        sort(x,x+4);
        sort(y,y+4);
        printf("%.2lf\n",(x[2]-x[1])*(y[2]-y[1]));
    }
}

 

HDoj 2056 Rectangles

标签:ali   不能   pid   com   and   second   blank   cal   lan   

原文地址:https://www.cnblogs.com/wzmm/p/12704621.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!