码迷,mamicode.com
首页 > 其他好文 > 详细

3927Circular Sequence 思维题(求环形最大子列和)

时间:2020-05-16 10:45:50      阅读:69      评论:0      收藏:0      [点我收藏+]

标签:cal   nta   size   tin   +=   eve   com   直接   names   

Given a sequence with n elements, if the last element is also adjacent to the first element of the sequence, the sequence is called “circular sequence”.
Now, here comes a simple problem: given a circular sequence, you should find a segment of the sequence, such that it contains at least one element, and the sum of the elements is as large as possible. 

 

输入

 

Input may contain several test cases. The first line is a single integer t, the number of test cases below. Each test case is composed of two lines. The first line of each test case is a positive integer n (1<=n<=100000), denoting the number of elements in the circular sequence, and the second line has n integers; the absolute value of each integer is no more than 100000. 

 

输出

 

For each test case, output the maximum segment sum in a single line. 

 

样例输入

2
2
-1 -2
3
1 -2 3

样例输出

-1

4

不考虑环:直接找非循环子序列maxsum1;

然后考虑循环:也就是两头相加情况,这是找非循环子序列minsum,把总和-minsum又得到一个maxsum2;

但前提的要有负数存在,负数不存在的话就直接是总和了;

否则就是max(maxsum1,maxsum2)

技术图片
#include<bits/stdc++.h>
using namespace std;
#define ll long long
ll a[100005];
int main()
{
    int i,j,t,n;scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        ll maxx=-0x3f3f3f3f,minn=0x3f3f3f3f;
        ll sum=0,s=0;
        int f=0;
        for(i=0;i<n;i++){
            scanf("%I64d",&a[i]);
            if(a[i]>=0)f=1;
            s+=a[i];
            sum+=a[i];
            maxx=max(maxx,sum);
            if(sum<0)sum=0;
        }
        sum=0;
        for(i=0;i<n;i++){
            sum+=a[i];
            minn=min(minn,sum);
            if(sum>0)sum=0;
        }
        if(f==1)maxx=max(maxx,s-minn);
        printf("%I64d\n",maxx);
    }
    return 0;
}
View Code

 

3927Circular Sequence 思维题(求环形最大子列和)

标签:cal   nta   size   tin   +=   eve   com   直接   names   

原文地址:https://www.cnblogs.com/ydw--/p/12515633.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!