码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4283 You Are the One

时间:2020-06-20 23:47:01      阅读:57      评论:0      收藏:0      [点我收藏+]

标签:least   ++   调整   director   main   att   using   put   line   

题目:You Are the One

网址:http://acm.hdu.edu.cn/showproblem.php?pid=4283

Problem Description

  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls.
  
Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one.

However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people.

Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input

The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)

The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

Output

For each test case, output the least summary of unhappiness.

Sample Input
2
  
5
1
2
3
4
5

5
5
4
3
2
2
Sample Output
Case #1: 20
Case #2: 24

考虑第i~j个人。
不难想到区间DP:dp[i, j]。
若第i个人是第1个人上台(i~j中),那么dp[i, j]转移至dp[i + 1, j];
否则,不妨令此人是第k个人上台。那么不难发现,在这样的一种排序方式中,前k - 1上台的人一定是i之后连续k - 1个人顺序有所调整。

则必有:dp[i, j] = max{\(dp[i + 1, j], dp[i + 1, i + k - 1] + dp[i + k] + (k - 1) * D[i] + \displaystyle\sum_{i - k}^{j}{D[l]} * k\)};

显然正确。

代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
const int maxn = 100 + 5;
int n, d[maxn], dp[maxn][maxn], sum[maxn];
void init()//初始化
{
	memset(sum, 0, sizeof(sum));
	memset(dp, 0, sizeof(dp));
	memset(d, 0, sizeof(d));
	return;
}
int main()
{
	int T;
	scanf("%d", &T);
	for(int t = 1; t <= T; ++ t)
	{
		scanf("%d", &n);
		init();
		for(int i = 1; i <= n; ++ i) scanf("%d", &d[i]);
		for(int i = 1; i <= n; ++ i)
		{
			sum[i] = sum[i - 1] + d[i];
		}
		for(int len = 2; len <= n; ++ len)
		{
			for(int i = 1, j = len; j <= n; ++ i, ++ j)
			{
				dp[i][j] = 1 << 30;
				for(int k = 1; k <= len; ++ k)
				{
					dp[i][j] = min(dp[i][j], dp[i + 1][i + k - 1] + (k - 1) * d[i] + dp[i + k][j] + k * (sum[j] - sum[i + k - 1]));//转移
				}
			}
		}
		printf("Case #%d: %d\n", t, dp[1][n]);
	}
	return 0;
}

HDU4283 You Are the One

标签:least   ++   调整   director   main   att   using   put   line   

原文地址:https://www.cnblogs.com/zach20040914/p/13170775.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!