码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2844

时间:2014-05-18 15:56:34      阅读:264      评论:0      收藏:0      [点我收藏+]

标签:style   blog   class   code   c   tar   

题目链接:

点击打开链接

题目:

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
8 4
 

Source
 

Recommend
gaojie
背包模板果然好用。。。
是一个多重背包转换成二进制背包的典型例子。。。
就是相当于1——m的背包能否装满。。。。即价值为i。。。


代码如下:

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=100000+10;
int dp[maxn],v[105],Count[105],m;
void zeroonepack(int cost,int value)
{
    for(int i=m;i>=cost;i--)
        dp[i]=max(dp[i],dp[i-cost]+value);
}

void completepack(int cost,int value)
{
    for(int i=cost;i<=m;i++)
        dp[i]=max(dp[i],dp[i-cost]+value);
}

void multiplepack(int cost,int value,int amount)
{
    int k=1;
    if(cost*amount>=m)
        completepack(cost,value);
    else
    {
        while(k<amount)
        {
            zeroonepack(k*cost,k*value);
            amount-=k;
            k*=2;
        }
        zeroonepack(amount*cost,amount*value);
    }
}


int main()
{
    int i,j,n,min_count;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        min_count=0;
        if(n==0&&m==0) return 0;
        for(i=1;i<=n;i++)
            scanf("%d",&v[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&Count[i]);
        for(i=1;i<=n;i++)
        {
            multiplepack(v[i],v[i],Count[i]);
        }
        for(i=1;i<=m;i++)
        {
            if(dp[i]==i)
                min_count++;
        }
        printf("%d\n",min_count);

    }
    return 0;



hdu2844,布布扣,bubuko.com

hdu2844

标签:style   blog   class   code   c   tar   

原文地址:http://blog.csdn.net/u014303647/article/details/26073613

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!