码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-4734-F(x)

时间:2014-05-18 06:35:50      阅读:300      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   c   

Problem Description
For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
3 0 100 1 10 5 100
 

Sample Output
Case #1: 1 Case #2: 2 Case #3: 13
 

Source

一道很简单的数位DP!!!!DP[pos][sum] 记录的是长度为pos小于等于sum的个数,这样就不用每次都初始化,我一开始DP记录的是长度为pos,前len-pos个数和sum的个数,因为每组样例DP的值不一定相同 如 1 10 dp[0][0] = 1; 而 2 100 dp[0][0] = 2;因此每次都需要初始化,这也是导致超时的原因。
这是一道很好的DP题!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int dp[12][4600];
int A,B;
int F;
vector <int> digit;
void init(){
    F = 0;
    int t = 0;
    while(A){
        F += (A%10)*(1<<t);
        t++;
        A/=10;
    }
}
int dfs(int pos,int val,int done){
    if(pos==-1) return 1;
    if(!done&& ~dp[pos][val]) return dp[pos][val];
    int res = 0;
    int end = done?digit[pos]:9;
    for(int i = 0; i <= end; i++){
        if(val + i*(1<<pos) > F) break;
        res += dfs(pos-1,val + i*(1<<pos),done&&i==end);
    }
    if(!done) dp[pos][val] = res;
    return res;
}
int solve(int num){
    digit.clear();
    while(num){
        digit.push_back(num%10);
        num /= 10;
    }
    return dfs(digit.size()-1,0,1);
}
int main(){
    int ncase,T = 1;
    cin >> ncase;
    memset(dp,-1,sizeof dp);
    while(ncase--){
        cin >> A >> B;
        init();
        printf("Case #%d: %d\n",T++,solve(B));
    }
    return 0;
}




HDU-4734-F(x),布布扣,bubuko.com

HDU-4734-F(x)

标签:des   style   blog   class   code   c   

原文地址:http://blog.csdn.net/mowayao/article/details/25998705

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!