码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2845——Beans

时间:2014-11-26 22:40:40      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:dp

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3011    Accepted Submission(s): 1450


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
bubuko.com,布布扣


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn‘t beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
242
 

Source
 

Recommend

先每行求一下最大值,dp1[i] = max(dp[i - 1], dp[i - 2] + cow[i]);
再对这些最大值求一个最大值
dp2[i] = max(dp2[i - 1], dp2[i - 2] + col[i]);

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;
int cow[200010];
int dp[200010];
int col[200010];
int dp2[200010];

int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		memset (dp2, 0, sizeof(dp2));
		for (int i = 1; i <= n; ++i)
		{
			memset (dp, 0, sizeof(dp));
			for (int j = 1; j <= m; ++j)
			{
				scanf("%d", &cow[j]);
			}
			dp[1] = cow[1];
			for (int j = 2; j <= m; ++j)
			{
				dp[j] = max(dp[j - 1], dp[j - 2] + cow[j]);
			}
			col[i] = dp[m];
		}
		dp2[1] = col[1];
		for (int i = 2; i <= n; ++i)
		{
			dp2[i] = max(dp2[i - 1], dp2[i - 2] + col[i]);
		}
		printf("%d\n", dp2[n]);
	}
	return 0;
}



hdu2845——Beans

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/41522513

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!