码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3612——Telephone Wire

时间:2014-12-06 16:53:28      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:dp

Telephone Wire
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2662   Accepted: 970

Description

Farmer John‘s cows are getting restless about their poor telephone service; they want FJ to replace the old telephone wire with new, more efficient wire. The new wiring will utilize N (2 ≤ N ≤ 100,000) already-installed telephone poles, each with some heighti meters (1 ≤ heighti ≤ 100). The new wire will connect the tops of each pair of adjacent poles and will incur a penalty cost C × the two poles‘ height difference for each section of wire where the poles are of different heights (1 ≤ C ≤ 100). The poles, of course, are in a certain sequence and can not be moved.

Farmer John figures that if he makes some poles taller he can reduce his penalties, though with some other additional cost. He can add an integer X number of meters to a pole at a cost of X2.

Help Farmer John determine the cheapest combination of growing pole heights and connecting wire so that the cows can get their new and improved service.

Input

* Line 1: Two space-separated integers: N and C
* Lines 2..N+1: Line i+1 contains a single integer: heighti

Output

* Line 1: The minimum total amount of money that it will cost Farmer John to attach the new telephone wire.

Sample Input

5 2
2
3
5
1
4

Sample Output

15

Source

USACO 2007 November Gold

设dp[i][j] 表示 第i根长度为j时的最优值,直接O(n)转移是会超时的,具体方法参见代码

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cstdlib>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100010;
const int inf = 0x3f3f3f3f;
int dp[N][105];
int low[200], high[200];
int h[N];

int main()
{
	int n, c;
	while (~scanf("%d%d", &n, &c))
	{
		memset (dp, inf, sizeof(dp));
		memset (low, inf, sizeof(inf));
		memset (high, inf, sizeof(high));
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &h[i]);
		}
		for (int i = h[1]; i <= 100; ++i)
		{
			dp[1][i] = (i - h[1]) * (i - h[1]);
		}
		for (int i = 1; i <= 100; ++i)
		{
			low[i] = min(low[i - 1], dp[1][i] - c * i);
		}
		for (int i = 100; i >= 1; --i)
		{
			high[i] = min(high[i + 1], dp[1][i] + c * i);
		}
		for (int i = 2; i <= n; ++i)
		{
			for (int j = h[i]; j <= 100; ++j)
			{
				dp[i][j] = min(low[j] + j * c, high[j] - j * c) + (j - h[i]) * (j - h[i]);
			}
			memset (low, inf, sizeof(inf));
			memset (high, inf, sizeof(high));
			for (int j = 1; j <= 100; ++j)
			{
				low[j] = min(low[j - 1], dp[i][j] - c * j);
			}
			for (int j = 100; j >= 1; --j)
			{
				high[j] = min(high[j + 1], dp[i][j] + c * j);
			}
		}
		int ans = inf;
		for (int i = h[n]; i <= 100; ++i)
		{
			ans = min(ans, dp[n][i]);
		}
		printf("%d\n", ans);
	}
	return 0;
}


POJ3612——Telephone Wire

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/41776411

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!