码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1330 Nearest Common Ancestors

时间:2014-05-21 03:23:51      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   c   code   

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

bubuko.com,布布扣
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

 这个题目最快的解法肯定是LCA了,可是我们也要看看数据嘛!由于只有一个询问,所以普通解法也能过,o(n)的算法也是很快的

bubuko.com,布布扣
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<cmath>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#define  inf 0x0f0f0f0f
using namespace std;

const int maxn=10000+10;
int parent[maxn],n;
bool vis[maxn];

void init()
{
    for (int i=0;i<=n;i++) parent[i]=i;
}

void input()
{
    int x,y;
    scanf("%d",&n);
    for (int i=1;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        parent[y]=x;
    }
}

int main()
{
    int t,x,y;
    scanf("%d",&t);
    while (t--)
    {
        init();
        input();
        scanf("%d%d",&x,&y);
        memset(vis,0,sizeof(vis));
        while (parent[x]!=x)
        {
            vis[x]=true;
            x=parent[x];
        }
        vis[x]=true;
        int ans=x;
        while(parent[y]!=y)
        {
            if (vis[y])
            {
                ans=y;
                break;
            }
            y=parent[y];
        }
        printf("%d\n",ans);
    }
    return 0;
}
bubuko.com,布布扣

 

poj 1330 Nearest Common Ancestors,布布扣,bubuko.com

poj 1330 Nearest Common Ancestors

标签:des   style   blog   class   c   code   

原文地址:http://www.cnblogs.com/chensunrise/p/3739526.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!