码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1458 Common Subsequence.(最长公共子序列)

时间:2014-05-21 10:58:39      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:poj 1458   common subsequence   最长公共子序列   a subsequence of a g   

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

====

DP.

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;

int const N=500;
int dp[N][N];
string a,b;

int main()

{
    while(cin>>a>>b)
    {
        int n=a.length(),m=b.length();
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            {
                if(a[i-1]==b[j-1]) dp[i][j]=dp[i-1][j-1]+1;
                else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        cout<<dp[n][m]<<endl;
    }
    return 0;
}






POJ 1458 Common Subsequence.(最长公共子序列),布布扣,bubuko.com

POJ 1458 Common Subsequence.(最长公共子序列)

标签:poj 1458   common subsequence   最长公共子序列   a subsequence of a g   

原文地址:http://blog.csdn.net/darwin_/article/details/26370091

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!