码迷,mamicode.com
首页 > 其他好文 > 详细

calculate the sum of some integers

时间:2014-05-23 06:41:47      阅读:298      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   c   code   

Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

2
4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
bubuko.com,布布扣
#include<iostream>
using namespace std;


int main()
{
    int N1=0,x=0;
    int **arrayN;
    cin>>N1;
    arrayN=new int*[N1];
    for(int i=0;i<N1;i++)
    {
        cin>>x;
        arrayN[i]=new int [x+1];
        for(int j=1;j<x+1;j++)
        {
            cin>>arrayN[i][j];
        }
        arrayN[i][0]=x;
    }

    int *sum=new int [N1];
    for(int i=0;i<N1;i++)
    {
        sum[i]=0;
    }
    for(int i=0;i<N1;i++)
    {
        int k=arrayN[i][0];
        for(int j=1;j<k+1;j++)
        {
            sum[i]+=arrayN[i][j];
        }
    }
    for(int i=0;i<N1;i++)
    {
        cout<<sum[i]<<endl;
    }
    return 0;
}
bubuko.com,布布扣

 

 

calculate the sum of some integers,布布扣,bubuko.com

calculate the sum of some integers

标签:des   style   class   blog   c   code   

原文地址:http://www.cnblogs.com/brock-1993/p/3741683.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!