码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4405——Aeroplane chess

时间:2014-12-19 13:04:33      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:dp

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1760    Accepted Submission(s): 1181


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:  5145 5144 5143 5142 5140

简单的概率dp题,考虑每一个位置i可以走到哪几个位置,如果当前位置没有飞行路线,那么dp[i] = (1/6)*dp[i + 1] + (1/6)*dp[i + 2] + (1/6)*dp[i + 3] + (1/6)*dp[i + 4] + (1/6)*dp[i + 5] + (1/6)*dp[i + 6] + 1

如果当前有路线,则dp[i] = dp[fly[i]](此时不用掷骰子)

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100100;
double dp[N];
int n, m;
int fly[N];

int main()
{
	int x, y;
	while (~scanf("%d%d", &n, &m))
	{
		if (!n && !m)
		{
			break;
		}
		for (int i = 0; i <= n; ++i)
		{
			fly[i] = -1;
			dp[i] = 0;
		}
		for (int i = 0; i < m; ++i)
		{
			scanf("%d%d", &x, &y);
			fly[x] = y;
		}
		for (int i = n - 1; i >= 0; --i)
		{
			if (fly[i] != -1)
			{
				dp[i] = dp[fly[i]];
			}
			else
			{
				for (int j = 1; j <= 6; ++j)
				{
					if (i + j >= n)
					{
						dp[i] += (1.0 + dp[n]) / 6;
					}
					else
					{
						dp[i] += (1.0 + dp[i + j]) / 6;
					}
				}
			}
		}
		printf("%.4f\n", dp[0]);
	}
	return 0;
}


hdu4405——Aeroplane chess

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/42026849

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!