码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2392Space Elevator(多重背包)

时间:2014-12-19 22:03:07      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:dp   algorithm   

Space Elevator
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8701   Accepted: 4135

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

大意:有K种block去建塔,每种每个都有一个高度H,用了当前的block塔的高度不能超出a,和每种的数量。求塔最高能建多高。

分析:这题就是一个多重背包,但有一点变动,必须先以a从小到大排序,因为如果先用了充许塔最高的block,而那种block的h很小,个数很少,更新自然就小,那么接下来小的就充许塔高越建越小,这样就不是我们所求的塔高了。如果先用a小的类形,就有变动更大的余地。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    int h,a,c;
}block[405];

bool cmp(node a,node b)
{
    return a.a<b.a;
}

int main()
{
    int dp[40005],k,maxa;
    while(scanf("%d",&k)>0)
    {
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        maxa=0;

        for(int i=0;i<k;i++)
            scanf("%d%d%d",&block[i].h,&block[i].a,&block[i].c);
        sort(block,block+k,cmp);

        int h,a,c;
        for(int i=0;i<k;i++)
        {
            h=block[i].h;
            a=block[i].a;
            c=block[i].c;

            if(maxa<a)
                 maxa=a;
            if(h*c>=a)
            {
                for(int i=h;i<=a;i++)
                    if(dp[i-h])
                     dp[i]=1;
            }
            else
            {
                int m=1;
                while(c>m)
                {
                    for(int i=a;i>=h*m; i--)
                        if(dp[i-h*m])
                         dp[i]=1;
                    c-=m; m*=2;
                }
                if(c)
                    for(int i=a;i>=h*c; i--)
                        if(dp[i-h*c])
                         dp[i]=1;
            }
        }
        for( ; maxa>=0; maxa--)
        if(dp[maxa])
        {
            printf("%d\n",maxa); break;
        }
    }
}


POJ2392Space Elevator(多重背包)

标签:dp   algorithm   

原文地址:http://blog.csdn.net/u010372095/article/details/42032029

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!