码迷,mamicode.com
首页 > 其他好文 > 详细

uva 101 History Grading

时间:2014-05-23 00:14:42      阅读:386      评论:0      收藏:0      [点我收藏+]

标签:style   blog   class   c   code   ext   

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events bubuko.com,布布扣 as bubuko.com,布布扣 where bubuko.com,布布扣denotes the ranking of event i in the correct chronological order and a sequence of student responses bubuko.com,布布扣 where bubuko.com,布布扣 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events withbubuko.com,布布扣 . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student‘s chronological ordering of the n events. All lines will contain nnumbers in the range bubuko.com,布布扣 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

思路:咋一眼一看这道题就很像最长增子串序列问题,只不过有一点变化,该题目的在判断d[i]与d[j]相比时,b[i]数字能否算在b[j]序列后面,必须要看标准答案中这2个数字的前后顺序。另外,这题的输入是个很大的坑,他的输入是按照顺序,事件1是排在第几位,事件2是排在第几位......, 所以要先把输入转换成正确的顺序。(其次,也有人认为该题目可以用最长公共子序列模板题,发现其实也是可以的。在此,我给出最长增子序列做法,答案已通过
#include<iostream>
#include<fstream>
#include<stdio.h>
using namespace std;
#define MAXSIZE 25
int a[MAXSIZE];   //用来存放标准答案
int d[MAXSIZE];    //用来表示状态

bool compare(int x,int y)  //判断在正确答案中y数据是否在x数据前面
{
    int i;
    for(i=0;i<MAXSIZE;i++)
    {
        if(a[i]==x)
            return true;
        else if(a[i]==y)
            return false;
        else
            ;
    }
    return false;
}
int main()
{
    //ofstream fcout("b.txt");
    //freopen("a.txt","r",stdin);
    int number,i,j;
    cin>>number;
    int temp;
    for(i=0;i<number;i++)
    {
        cin>>temp;
        a[temp]=i+1;
    }
    int b[MAXSIZE];
    int max_score;
    while(cin>>temp)
    {
        b[temp]=1;
        for(i=1;i<number;i++)
        {
            cin>>temp;
            b[temp]=i+1;
        }

        //for(i=1;i<number+1;i++)
           // fcout<<b[i]<<" ";
        //fcout<<endl;
        d[1]=1;
        max_score=d[1];
        for(i=2;i<number+1;i++)
        {
            d[i]=1;
            for(j=1;j<i;j++)
            {
                if(compare(b[j],b[i])&&d[j]+1>d[i])
                    d[i]=d[j]+1;
            }
            if(d[i]>max_score)
                max_score=d[i];
        }
        cout<<max_score<<endl;
    }
    return 0;
}



uva 101 History Grading,布布扣,bubuko.com

uva 101 History Grading

标签:style   blog   class   c   code   ext   

原文地址:http://blog.csdn.net/bb2b2bbb/article/details/26549497

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!