码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5155---Harry And Magic Box

时间:2015-01-04 10:06:10      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:dp

Harry And Magic Box

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 131    Accepted Submission(s): 64


Problem Description
One day, Harry got a magical box. The box is made of n*m grids. There are sparking jewel in some grids. But the top and bottom of the box is locked by amazing magic, so Harry can’t see the inside from the top or bottom. However, four sides of the box are transparent, so Harry can see the inside from the four sides. Seeing from the left of the box, Harry finds each row is shining(it means each row has at least one jewel). And seeing from the front of the box, each column is shining(it means each column has at least one jewel). Harry wants to know how many kinds of jewel’s distribution are there in the box.And the answer may be too large, you should output the answer mod 1000000007.
 

Input
There are several test cases.
For each test case,there are two integers n and m indicating the size of the box. 0n,m50.
 

Output
For each test case, just output one line that contains an integer indicating the answer.
 

Sample Input
1 1 2 2 2 3
 

Sample Output
1 7 25
Hint
There are 7 possible arrangements for the second test case. They are: 11 11 11 10 11 01 10 11 01 11 01 10 10 01 Assume that a grids is ‘1‘ when it contains a jewel otherwise not.
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:  5157 5156 5153 5152 5151

一开始想复杂了,想了个三维dp,dp[i][j][k]表示放了k个棋子,现在有i行j列是亮的
然后悲剧了半天还是没调出来

dp[i][j] 表示在前i行,每一行都亮,而一共有j列是亮的

考虑第i行放k个,亮t个
dp[i][j + t] = dp[i - 1][j] * C[m - j][t] * C[j][k - t]

/*************************************************************************
    > File Name: hdu5155.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月03日 星期六 21时52分09秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int mod = 1000000007;
long long dp[55][55];
long long C[55][55];

void Combine()
{
	memset (C, 0, sizeof(C));
	C[0][0] = 1;
	for (int i = 1; i <= 50; ++i)
	{
		C[i][0] = 1;
		for (int j = 1; j <= i; ++j)
		{
			if (i == j)
			{
				C[i][j] = 1;
			}
			else if (j == 1)
			{
				C[i][j] = i;
			}
			else
			{
				C[i][j] = C[i - 1][j - 1] + C[i - 1][j];
				C[i][j] %= mod;
			}
//			printf("%d\n", C[i][j]);
		}
	}
}

int main()
{
	Combine();
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		memset (dp, 0, sizeof(dp));
		dp[0][0] = 1;
		for (int i = 1; i <= n; ++i)
		{
			for (int j = 0; j <= m; ++j) //前i - 1行亮的列数
			{
				for (int k = 1; k <= m; ++k)//这一行放了k个
				{
					for (int t = 0; j + t <= m; ++t)//这一行亮t个
					{
						if (k - t < 0)
						{
							continue;
						}
						long long tmp = dp[i - 1][j] * C[m - j][t];
						tmp %= mod;
						tmp *= C[j][k - t];
						tmp %= mod;
						dp[i][j + t] += tmp;
						dp[i][j + t] %= mod;
					}
				}
			}
		}
		printf("%lld\n", dp[n][m]);
	}
	return 0;
}


hdu5155---Harry And Magic Box

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/42375031

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!