码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 1009 FatMouse' Trade

时间:2014-05-25 21:54:02      阅读:288      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   c   code   

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40975    Accepted Submission(s): 13563


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

Author
CHEN, Yue
简单背包     J[i]与F[i]比例大的先拿  注意J F数组要随着比例一起排序。。。。。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct food{
    double j;
    double f;
    double p;
}a[1005];
int cmp(food b,food c)
{
    return b.p>c.p;
}
int main()
{
    int m,n,i,k;
    double sum,l,s;
    while(~scanf("%d%d",&n,&m))
    {
        sum=0;
        s=0;
        l=0;
        if((n==-1)&&(m==-1))
            break;
        for(i=0;i<m;i++)
            scanf("%lf%lf",&a[i].f,&a[i].j);
        for(i=0;i<m;i++)
            {
                a[i].p=a[i].f/a[i].j;
            }

       sort(a,a+m,cmp);
        for(i=0;i<m;i++)
            {
                    {s+=a[i].j;k=i;}
                if(s>n)
                    {l=n-(s-a[i].j);break;}

            }

            for(i=0;i<k;i++)
                    {sum+=a[i].f;}
                    if((int)l)
                        sum+=l*a[k].p;
                printf("%.3lf\n",sum);
    }
return 0;
}


 

杭电 1009 FatMouse' Trade,布布扣,bubuko.com

杭电 1009 FatMouse' Trade

标签:des   style   class   blog   c   code   

原文地址:http://blog.csdn.net/fanerxiaoqinnian/article/details/26954595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!