码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3396 Conference Call

时间:2014-06-05 02:12:20      阅读:372      评论:0      收藏:0      [点我收藏+]

标签:c   style   class   blog   code   a   


Good News! Utopia Polycom begins to offer a whole new service, Conference Call. This new service enables three users to make phone calls at the same time and talk to each other. It‘s very useful when several people are discussing about one shared topic. For example, Tom, Rosemary and you plan to go picnic tomorrow. You just need to make one conference call, so that you can discuss with Tom and Rosemary simultaneously. It‘s extremely convenient, yes?

However, it has a lot of technological problems to start this service. It took engineers of Utopia Polycom five years to conquer all these problems. One of the biggest problem is how to make the communication line connected. To solve this problem, they have constructed a powerful net of transfer stations. Every single phone is connected to its nearest transfer station, some transfer stations are connected to each other by wires. When to make a conference call, signal will start from the dialling telphone. The signal will be transferred through transfer stations and finally reach the other two phones.

Since the distances between each two transfer stations are various, the cost for the signal to go through the wires is different as well. Assume there are n telphones(numbered from 1 to n) and m(numbered from 1 to m) transfer stations in this communication net. The total cost for a line is the sum of the costs of the wires in the line. Our problems remains, what is the minimal total cost to make a conference call among three telphone a, b and c. As showing below, the minimal total cost to make a conference call among telphone 1, 2, 3 is 12.

bubuko.com,布布扣

Input

There are multiple cases. For each test case, the first line contain three positive integers, n (n ≤ 10000), m (m ≤ 500), l (l ≤ 10000). l means the number of wires. Then follows n lines. Each line contains one integer ti (1 ≤ tim), which means the number of transfer station No.i telphone is connected to. Then follows l lines, each line contains three integers a, b, C (1 ≤ C ≤ 500), which means a and b transfer stations are connected to each other by a wire with the amount of cost C. If a pair (a, b) doesn‘t appear in these l lines, that means tranfer stations a, b are not connected.

The next line is a single integer q (q ≤ 50). Then follow q lines. Each line contains three integers x, y, z. You are supposed to calculate the minimal total cost to make a conference call among telphone x, y, z. Each test case is seperated by a blank line. Proceed to the end of the file.

Output

For each test case i, print case number in the form "Case #i" in one single line. Then for each inquiry j, print one line in the form "Line j: " and if the conference call can be made and the minimal total cost is Min, print the sentense "The minimum cost for this line is Min." else you should print "Impossible to connect!". Look at the samples for details.

Sample Input

3 5 5
2
1
5
1 2 6
2 3 1
3 4 2
4 5 3
1 5 12
1
1 2 3

3 3 1
1
2
3
2 3 4
1
1 2 3

Sample Output

Case #1
Line 1: The minimum cost for this line is 12.
Case #2
Line 1: Impossible to connect!

题意:现在某公司推出一项新项目,支持三个人之间的电话通化,每台电话连接一个最近的中转站,然而要进行通话,是需要在中转站上传输信号,传输的距离越长费用就越高,求出给定的三台电话的通话所需的最短路程。
思路:使用floyd算法就出每两个城市之间的最短路径,然后依据这些路径求出三台电话之间的最短路径。求的时候还是有一个大坑的,不能只枚举给定三个城市之间的最短路。例如:看下图,假设求A,B,C三点的最短路,如果只涉及A,B,C三点的话,求出的路径显然不是最短的,假设以D为中心,求出来的路径肯定比刚才的路径要短。
bubuko.com,布布扣
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#define INF 100000000
using namespace std;
int root[10004];         //用来存储每台电话最近的中转站
int f[504][504];
int n,m,l;
void init()
{
    for(int i=0; i<=n; i++)
        for(int j=0; j<=i; j++)
        {
            if(i!=j) f[i][j]=f[j][i]=INF;
            else f[i][j]=0;
        }
}

void floyd()
{
    for(int k=1;k<=n;k++)
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++)
    {
        if(f[i][j]>f[i][k]+f[k][j])
        {
            f[i][j]=f[i][k]+f[k][j];
        }
    }
}
int main()
{
    int ans=1;
    while(scanf("%d%d%d",&m,&n,&l)!=EOF)
    {
        init();
        for(int i=1;i<=m;i++)
        scanf("%d",&root[i]);
        int x,y,z;
        for(int i=0;i<l;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(f[x][y]>z) f[x][y]=f[y][x]=z;
        }
        floyd();
        scanf("%d",&l);
        printf("Case #%d\n",ans++);
        for(int i=1;i<=l;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            x=root[x];
            y=root[y];
            z=root[z];
            int sum=INF;
            for(int i=1;i<=n;i++)          //本题关键,很坑....
            {
                if(sum>f[i][x]+f[i][y]+f[i][z])
                    sum=f[i][x]+f[i][y]+f[i][z];
            }

            printf("Line %d: ",i);
            if(sum>=INF) printf("Impossible to connect!\n");
            else printf("The minimum cost for this line is %d.\n",sum);
        }
    }
    return 0;
}

zoj 3396 Conference Call,布布扣,bubuko.com

zoj 3396 Conference Call

标签:c   style   class   blog   code   a   

原文地址:http://blog.csdn.net/knight_kaka/article/details/27229475

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!