码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2769 Reduced ID Numbers(memset使用技巧)

时间:2014-06-01 07:40:18      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:des   c   style   class   blog   code   

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int t[310];
bool vis[1000010];

int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m,i,j;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
            cin>>t[i];
        for(i=m;;i++)
        {
            memset(vis,false,i*sizeof(vis[0])); //时间172ms
            for(j=1;j<=m;j++)                   //memset(vis,false,sizeof(vis));    tle
            if(vis[t[j]%i]) break;
            else vis[t[j]%i]=true;
            if(j>m) break;
        }
        printf("%d\n",i);
    }
    return 0;
}


poj 2769 Reduced ID Numbers(memset使用技巧),布布扣,bubuko.com

poj 2769 Reduced ID Numbers(memset使用技巧)

标签:des   c   style   class   blog   code   

原文地址:http://blog.csdn.net/u010650359/article/details/27832647

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!