码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2457---DNA repair(AC自动机+dp)

时间:2015-03-05 21:03:31      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:ac自动机   dp   

Problem Description
Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters ‘A’, ‘G’ , ‘C’ and ‘T’. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA “AAGCAG” to “AGGCAC” to eliminate the initial causing disease segments “AAG”, “AGC” and “CAG” by changing two characters. Note that the repaired DNA can still contain only characters ‘A’, ‘G’, ‘C’ and ‘T’.

You are to help the biologists to repair a DNA by changing least number of characters.

Input
The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.
The following N lines gives N non-empty strings of length not greater than 20 containing only characters in “AGCT”, which are the DNA segments causing inherited disease.
The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in “AGCT”, which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

Output
For each test case, print a line containing the test case number( beginning with 1) followed by the
number of characters which need to be changed. If it’s impossible to repair the given DNA, print -1.

Sample Input

2 AAA AAG AAAG 2 A TG TGAATG 4 A G C T AGT 0

Sample Output

Case 1: 1 Case 2: 4 Case 3: -1

Source
2008 Asia Hefei Regional Contest Online by USTC

Recommend
teddy | We have carefully selected several similar problems for you: 2458 2459 2456 2461 2462

设每一个模式串结尾所在的节点为危险节点,显然在AC自动机上,如果一个节点的fail指针指向的那个节点是危险节点,那么这个节点是危险节点,因为它们是后缀关系
设dp[i][j]表示长度为i,在节点j时,且不包含任何危险节点,所需要改变的最少的字符数

/*************************************************************************
    > File Name: hdu2457.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年03月05日 星期四 14时29分23秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int MAX_NODE = 2010;
const int CHILD_NUM = 4;
int dp[1010][MAX_NODE];

struct AC_Automation
{
    int next[MAX_NODE][CHILD_NUM];
    int fail[MAX_NODE];
    int end[MAX_NODE];
    int root, L;

    int ID (char c)
    {
        if (c == ‘A‘)
        {
            return 0;
        }
        if (c == ‘G‘)
        {
            return 1;
        }
        if (c == ‘C‘)
        {
            return 2;
        }
        if (c == ‘T‘)
        {
            return 3;
        }
    }

    int newnode ()
    {
        for (int i = 0; i < CHILD_NUM; ++i)
        {
            next[L][i] = -1;
        }
        end[L++] = 0;
        return L - 1;
    }

    void init ()
    {
        L = 0;
        root = newnode ();
    }

    void Build_Trie (char buf[])
    {
        int now = root;
        int len = strlen (buf);
        for (int i = 0; i < len; ++i)
        {
            if (next[now][ID(buf[i])] == -1)
            {
                next[now][ID(buf[i])] = newnode();
            }
            now = next[now][ID(buf[i])];
        }
        end[now] = 1;
    }

    void Build_AC ()
    {
        queue <int> qu;
        fail[root] = root;
        for (int i = 0; i < CHILD_NUM; ++i)
        {
            if (next[root][i] == -1)
            {
                next[root][i] = root;
            }
            else
            {
                fail[next[root][i]] = root;
                qu.push (next[root][i]);
            }
        }
        while (!qu.empty())
        {
            int now = qu.front();
            qu.pop();
            if (end[fail[now]])
            {
                end[now] = 1;
            }
            for (int i = 0; i < CHILD_NUM; ++i)
            {
                if (next[now][i] == -1)
                {
                    next[now][i] = next[fail[now]][i];
                }
                else
                {
                    fail[next[now][i]] = next[fail[now]][i];
                    qu.push (next[now][i]);
                }
            }
        }
    }  

    void solve(char buf[])
    {
        memset (dp, inf, sizeof(dp));
        dp[0][0] = 0;
        int len = strlen (buf);
        for (int i = 0; i < len; ++i)
        {
            for (int j = 0; j < L; ++j)
            {
                if (dp[i][j] < inf)
                {
                    for (int k = 0; k < 4; ++k)
                    {
                        int now = next[j][k];
                        if (end[now])
                        {
                            continue;
                        }
                        int use = dp[i][j];
                        if (k != ID(buf[i]))
                        {
                            ++use;
                        }
                        dp[i + 1][now] = min (dp[i + 1][now], use);
                    }
                }
            }
        }
        int ans = inf; 
        for (int i = 0; i < L; ++i)
        {
            ans = min (ans, dp[len][i]);
        }
        printf("%d\n", ans >= inf ? -1 : ans);
    }
}AC;

char buf[1010];

int main ()
{
    int n;
    int icase = 1;
    while (~scanf("%d", &n), n)
    {
        printf("Case %d: ", icase++);
        AC.init();
        for (int i = 1; i <= n; ++i)
        {
            scanf("%s", buf);
            AC.Build_Trie (buf);
        }
        AC.Build_AC();
        scanf("%s", buf);
        AC.solve (buf);
    }
    return 0;
}

hdu2457---DNA repair(AC自动机+dp)

标签:ac自动机   dp   

原文地址:http://blog.csdn.net/guard_mine/article/details/44086513

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!