码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3189 Treats for the Cows(两种DP方法解决)

时间:2015-03-11 14:58:38      阅读:261      评论:0      收藏:0      [点我收藏+]

标签:acm   编程   algorithm   dp   

Treats for the Cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4264   Accepted: 2155

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.


方法一

       按照题意直接dp,dp[i][j][2],i是第i天,j是有j个,0是从前面取,1是从后面取。接着就可以根据dp[i-1][j][0],dp[i-1][j][1]推出dp[i][j][1],根据dp[i-1][j-1][0],dp[i-1][j-1][1]推出dp[i][j][0]。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=2000+100;
int a[maxn];
int dp[maxn][maxn][2];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        int ans=max(a[1],a[n]);
        dp[1][1][0]=a[1];
        dp[1][0][1]=a[n];
        for(int i=2;i<=n;i++)
        {
            for(int j=i;j>=0;j--)
            {
                if((dp[i-1][j-1][0]||dp[i-1][j-1][1])&&j>0)
                dp[i][j][0]=max(dp[i-1][j-1][1],dp[i-1][j-1][0])+a[j]*i;
                if(dp[i-1][j][0]||dp[i-1][j][1])
                dp[i][j][1]=max(dp[i-1][j][0],dp[i-1][j][1])+a[n-i+j+1]*i;
                ans=max(ans,dp[i][j][0]);
                ans=max(ans,dp[i][j][1]);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

方法二(区间DP)

     dp[i][j],i表示区间起始点,j表示区间结束点,lg表示区间长度。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=2000+200;
int a[maxn];
int dp[maxn][maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;i++)
        dp[i][i]=a[i]*n;//区间长度为0,只有一个数,是最后出的数
        for(int lg=1;lg<n;lg++)
        {
            for(int i=1;i<=n;i++)
            {
                int j=i+lg;
                dp[i][j]=max(dp[i+1][j]+a[i]*(n-lg),dp[i][j-1]+a[j]*(n-lg));
                //这里是从最后出队的开始往前推,i~j可以从i+1~j和i~j-1推出
            }
        }
        printf("%d\n",dp[1][n]);
    }
}


     

POJ 3189 Treats for the Cows(两种DP方法解决)

标签:acm   编程   algorithm   dp   

原文地址:http://blog.csdn.net/caduca/article/details/44196239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!