码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1007 Quoit Design (分治)

时间:2014-06-20 10:46:06      阅读:524      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

Quoit Design


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
0.71 0.00 0.75
 

Author
CHEN, Yue
 

Source
 


题目大意:

给你很多点,问你最近点的距离一半是多少。

解题思路:

最近点对,参照:http://blog.csdn.net/hellobabygogo3/article/details/8042650

解题代码:(参照它的思路,感觉我的代码比较简洁一些)

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn=110000;

struct point{
    double x,y;
    double getdis(point p){
        return sqrt( (x-p.x)*(x-p.x)+(y-p.y)*(y-p.y) );
    }
    friend bool operator < (point a,point b){
        if(a.x!=b.x) return a.x<b.x;
        else return a.y<b.y;
    }
}p[maxn];

int n;

bool cmp(point a,point b){
    if(a.y!=b.y) return a.y<b.y;
    else return a.x<b.x;
}

double getmin(int l,int r){
    if(r-l==0) return 1e18;
    if(r-l==1) return p[l].getdis(p[r]);
    int mid=(l+r)/2;
    double ans=min( getmin(l,mid),getmin(mid+1,r) );
    vector <point> v;
    for(int i=l;i<r;i++){
        if( fabs(p[i].x-p[mid].x) < ans ) v.push_back(p[i]);
    }
    sort(v.begin(),v.end(),cmp);
    for(int i=0;i<v.size();i++){
        for(int j=i+1;j<v.size();j++){
            if(v[j].y-v[i].y>=ans)  break;
            double tmp=v[j].getdis(v[i]);
            if(tmp<ans) ans=tmp;
        }
    }
    return ans;
}

void solve(){
    double ans=1e18;
    sort(p,p+n);
    printf("%.2lf\n",getmin(0,n-1)/2.0);
}

int main(){
    while(scanf("%d",&n)!=EOF && n>0){
        for(int i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        solve();
    }
    return 0;
}


HDU 1007 Quoit Design (分治),布布扣,bubuko.com

HDU 1007 Quoit Design (分治)

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/a1061747415/article/details/28441285

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!