码迷,mamicode.com
首页 > 其他好文 > 详细

Uva 514 Rails

时间:2014-06-16 11:17:45      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.


bubuko.com,布布扣

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A hasbubuko.com,布布扣 coaches numbered in increasing orderbubuko.com,布布扣. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be bubuko.com,布布扣. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input 

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integerN described above. In each of the next lines of the block there is a permutation ofbubuko.com,布布扣 The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output 

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file containsYes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it containsNo. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null‘‘ block of the input file.

Sample Input 

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output 

Yes
No

Yes


题目是lrj白书上的一道题目,用栈模拟,练一下stack。


#include <stdio.h>
#include <stack>
#include <iostream>
using namespace std;
int tg[1005];
int main()
{
    int n;
    while ( cin >> n && n) {
        while(cin >> tg[1] && tg[1]) {
            for(int i=2;i<=n;i++) cin >> tg[i];
            int a=1,b=1,ok=0;
            stack<int> s;
            while( b <= n ) {
                if( a == tg[b] ) a++,b++;  //如果a站的头一个 与b站当前相等,直接a->b
                else if( !s.empty() && s.top() == tg[b] ) { s.pop(); b++; } // 否则 如果c里面的头一个与b当前相等,c->b。
                else if( a <= n ) s.push(a++); // 否则 只能将a->b
                else { ok=1; break; } //如果a站已经没车了,那么不符合要求
            }
            if(!ok) cout << "Yes";
            else cout << "No";
            cout << '\n';
        }
        cout << '\n';
    }
    return 0;
}




Uva 514 Rails,布布扣,bubuko.com

Uva 514 Rails

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/u013923947/article/details/30113451

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!