码迷,mamicode.com
首页 > 其他好文 > 详细

POJ训练计划3080_Blue Jeans(串处理/暴力)

时间:2014-06-14 17:48:12      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

Blue Jeans
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11542   Accepted: 4962

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

解题报告
真心不想写这解题报告。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char str[12][100],ch[100],ans[100];
int main()
{
    int t,i,j,k,n,maxl,f;
    cin>>t;
    while(t--)
    {
        memset(str,0,sizeof(str));
        memset(ans,0,sizeof(ans));
        cin>>n;
        maxl=0,f=0;
        for(i=0; i<n; i++)
            cin>>str[i];
        for(i=0; i<58; i++)
        {
            for(j=3; j<=60-i; j++)
            {
                strncpy(ch,str[0]+i,j);
                ch[j]=0;
                f=0;
                for(k=1; k<n; k++)
                {
                    if(strstr(str[k],ch)==NULL)
                    {
                        f=1;
                        break;
                    }
                }
                if(!f)
                {
                    if(j>maxl)
                    {
                        maxl=j;
                        strcpy(ans,ch);
                    }
                    else if(j==maxl)
                    {
                        if(strcmp(ch,ans)<0)
                            strcpy(ans,ch);
                    }
                }
            }
        }
        if(maxl)
            cout<<ans<<endl;
        else cout<<"no significant commonalities"<<endl;
    }
    return 0;
}


POJ训练计划3080_Blue Jeans(串处理/暴力),布布扣,bubuko.com

POJ训练计划3080_Blue Jeans(串处理/暴力)

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/juncoder/article/details/30505407

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!