码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3071 Football (动态规划-概率DP)

时间:2014-06-21 21:14:57      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2768   Accepted: 1412

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 ? pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number ?1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source


题目大意:

给定n,表示2^n次方个参赛者,接下来 2^n * 2^n 的矩阵,p[i][j] 表示 i 赢 j 的概率,现在是每次从1到2^n次方比赛,淘汰一半人,剩下的人在按照顺序比赛,1号和2号比,3号和4号 之类的顺序,问你最终谁赢的概率最大?


解题思路:

一道简单的概率DP题,只是我很cuo,看了别人的报告才会。

记dp[i][j]表示 第 i 场第 j 个人依然赢的概率。

那么转移就是:dp[i][j]=sum( dp[i-1][j]*p[j][k]*dp[i-1][k] )


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=(1<<8);
double dp[10][maxn],p[maxn][maxn];
int n;

void input(){
    for(int i=0;i<(1<<n);i++){
        for(int j=0;j<(1<<n);j++){
            scanf("%lf",&p[i][j]);
        }
    }
}

void solve(){
    for(int i=0;i<(1<<n);i++) dp[0][i]=1.0;//第0场第i支队伍存活的概率为1
    //dp[i][j]=sum( dp[i-1][j]*p[j][k]*dp[i-1][k] );
    for(int i=1;i<=n;i++){//枚举场数
        for(int j=0;j<(1<<n);j++){
            dp[i][j]=0;
            for(int k=0;k<(1<<n);k++){
                if( ( ( j>>(i-1) ) ^ 1 ) == ( k>>(i-1) ) ) dp[i][j]+=dp[i-1][j]*p[j][k]*dp[i-1][k];
            }
        }
    }
    int ans=0;
    for(int i=0;i<(1<<n);i++){
        //cout<<i+1<<":"<<dp[n][i]<<endl;
        if(dp[n][i]>dp[n][ans]) ans=i;
    }
    cout<<ans+1<<endl;
}

int main(){
    while(scanf("%d",&n)!=EOF && n!=-1){
        input();
        solve();
    }
    return 0;
}




POJ 3071 Football (动态规划-概率DP),布布扣,bubuko.com

POJ 3071 Football (动态规划-概率DP)

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/a1061747415/article/details/32727159

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!